I have started to development with Codeigniter 2.x version and no doubt it is good PHP framework to build web applications. Codeigniter is my first choice to build websites and applications, because it is fast, secured, easy to learn and more friendly than others. Now it is most used PHP framework around the world and users are more than 32%.

Earlier BCIT [ British Columbia Istitute of Technology ] announced Codeigniter 3.0, which would be better than last version in seecurity, coding structure manner. Let’s check now, what are new updates ? how they are useful for developers ? If they are stable like previous version or developers will need to learn something new ?

Security is big concern for websites and applications either they are being used for desktop, mobile or online. We all know who are hackers ? they don’t accept challage only to access the websites, but they also harms to users and steal their data and informations. So, framwork has released some new security patches to ensure this like XSS filtering.

Version 2 had an issue with this, but now un-authenticated users can’t by-pass this function. You can use this function as:-

$this->security->xss_clean();

Base_url() will fallback to $_SERVER[‘SERVER_ADDR’], when $config[‘base_url’] is empty in order to avoid Host header injections.

  • Updated PHP: Increases security and performance
    CodeIgniter requires PHP 5.2.4 and recommends 5.4+.. PHP 5.1.6 is not supported anymore.
  • File Naming Conventions: Improves standard coding practices
    Class file names now must be uppercase first and everything else lowercase
  • Database Performance: Makes queries faster
    The default database driver is changed to ‘mysqli’. The old ‘mysql’ driver has depreciated.
  • It will use new introduced Native Driver PHP session with Cookie Driver class, which will allows custom sessions.
  • To minify the output of your page request (primarily by removing spaces) you simply set theminify_output config setting in the config.php file to TRUE.

$ config[‘minify_output’] = TRUE;

  • You can use standard or custom HTTP verbs (GET, PUT, POST, etc), by adding the verb as an array key to your route

$ route[‘products’][‘put’] = ‘product/insert’;

  • Moved error templates to application/views/errors/and made the path configurable via $config[‘error_views_path’].
  • PHP 5.1.6 is no longer supported. CodeIgniter now requires PHP 5.2.4 and recommends PHP 5.4+ or newer to be used.
  • Active Record is renamed to Query Builder. C hanged the default database driver to ‘mysqli’ (the old ‘mysql’ driver is DEPRECATED).
  • Composer auto-loader
  • Updated ip_addressdatabase field lengths from 16 to 45 for supporting IPv6 address on Trackback Library and Captcha Helper.

If you have something to add to this blog? Kindly share it in the comments. Thank you for reading this.

30%* off! Get going with GoDaddy!

LEAVE A REPLY